Проблемы адаптера elm327 версии 2.1

Помощь в соединении хобдрайва с автомобилем, настройка и калибровка параметров автомобиля

Проблемы адаптера elm327 версии 2.1

kdika » 16 янв 2015, 22:57

Много негатива по адаптерам с версией 2.1.
Работают только с OBD2 протоколом, любые KWP2000 протоколы - поддерживают криво и плохо, в большинстве случаев связь с ЭБУ не устанавливается.

Не понимает он команд для соединения с ЭБУ, а некоторые неправильно воспринимает:

SendCommand:ATAL
HandleReply: ? - должно быть ОК
-> EXTRAINIT
SendCommand:ATIB10
HandleReply: ELM327 v2.1 - должно быть ОК
-> EXTRAINIT
SendCommand:ATSH8111F1
HandleReply: OK
-> EXTRAINIT
SendCommand:ATST32
HandleReply: OK
-> EXTRAINIT
SendCommand:ATSW00
HandleReply: ? - должно быть ОК


Если для подключения к вашему ЭБУ необходимо прописывать строку инициализации елм (использовать шаблон строки инициализации елм), команды (ATIB10, ATAL, ATSW00 ... ) которые неправильно отрабатывает елм приходят ответы знак вопроса (на ATIB10 должен быть ответ ОК, а не версия elm адаптера), то такой адаптер нестандартные протоколы (KWP2000) не поддерживает (ЭБУ: Январь, Микас, Делфи...Авто: ВАЗы, Chery Tiggo, Nissan, Toyota JDM...)
то связь вы не установите! И дело здесь не в программе!

Самостоятельно проверить елм можно с помощью Хобдрайва:
~ в системных настройках изменить уровень системных логов с error на trace
~ в параметрах авто выбрать шаблон строки инициализации elm: VAZ Yanvar
~ подсоединиться к елм, результат ответов посмотреть в log.txt (находится в папке с программой)
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

kdika » 20 янв 2015, 15:40

Не все адаптеры версии 2.1 "кривые", хотя их большинство.
Вот так выглядит лог нормально работающего адаптера с протоколом KWP2000
-> INIT
-> ATZ
SendCommand:ATZ
HandleReply: ELM327 v2.1
VersionInfo: ELM327 v2.1
-> ATE0
SendCommand:ATE0
HandleReply: ATE0

-> ATL0
SendCommand:ATL0
HandleReply: OK
-> EXTRAINIT
SendCommand:ATSP5
HandleReply: OK
-> EXTRAINIT
SendCommand:ATAL
HandleReply: OK
-> EXTRAINIT
SendCommand:ATIB10
HandleReply: OK
-> EXTRAINIT
SendCommand:ATSH8110F1
HandleReply: OK
-> EXTRAINIT
SendCommand:ATST32
HandleReply: OK
-> EXTRAINIT
SendCommand:ATSW00
HandleReply: OK
-> EXTRAINIT

-> QUERY_PROTOCOL
SendCommand:ATDPN
HandleReply: 5
ProtocolId: 5

-> SENSOR
----> ELM.BatteryVoltage
-> SENSOR_HEADER_ACK
SendCommand:ATRV

HandleReply: 13.3V
-> SENSOR
----> KWP.Core
-> SENSOR_HEADER_ACK
SendCommand:2101
-> SENSOR_ACK
HandleReply: 61 01 3B 92 42 82 00 00 00 00 5F 80 00 18 5F 3C 3C 84 18 00 B8 5F 6C 83 46 02 84 00 F4 02 40 00 FF FF D1 65 40 00


----> KWP.Core
-> SENSOR_HEADER_ACK
SendCommand:2101
HandleReply: 61 01 3B 92 42 82 00 00 00 00 5F 80 00 18 60 3C 3C 84 16 00 B8 5F 68 03 46 02 84 00 F5 02 40 00 FF FF D1 65 40 00
-> SENSOR
----> KWP.Core
-> SENSOR_HEADER_ACK
SendCommand:2101
-> SENSOR_ACK
HandleReply: 61 01 3B 92 42 82 00 00 00 00 5F 80 00 18 60 3C 3C 84 16 00 B8 5F 68 03 43 02 86 00 F1 02 40 00 FF FF D1 65 40 00
-> SENSOR
----> KWP.Core
-> SENSOR_HEADER_ACK
SendCommand:2101
-> SENSOR_ACK
HandleReply: 61 01 3B 92 42 82 00 00 00 00 5F 80 00 18 61 3C 3C 84 15 00 BA 5F 68 03 44 02 85 00 F3 02 40 00 FF FF D1 65 40 00


Как видно связь с адаптером и ЭБУ была установлена!
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

kdika » 18 мар 2015, 16:08

Лог с нормально работающего адаптера версии 2.1 снимался с Vgate ICar2 BT.
На вид он такой:
20140208101342928.jpg
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

mihail.razdrogov73754 » 19 дек 2015, 13:18

kdika писал(а):Много негатива по адаптерам с версией 2.1.
Работают только с OBD2 протоколом, любые KWP2000 протоколы - поддерживают криво и плохо, в большинстве случаев связь с ЭБУ не устанавливается.

Не понимает он команд для соединения с ЭБУ, а некоторые неправильно воспринимает:

SendCommand:ATAL
HandleReply: ? - должно быть ОК
-> EXTRAINIT
SendCommand:ATIB10
HandleReply: ELM327 v2.1 - должно быть ОК
-> EXTRAINIT
SendCommand:ATSH8111F1
HandleReply: OK
-> EXTRAINIT
SendCommand:ATST32
HandleReply: OK
-> EXTRAINIT
SendCommand:ATSW00
HandleReply: ? - должно быть ОК


Если для подключения к вашему ЭБУ необходимо прописывать строку инициализации елм (использовать шаблон строки инициализации елм), команды (ATIB10, ATAL, ATSW00 ... ) которые неправильно отрабатывает елм приходят ответы знак вопроса (на ATIB10 должен быть ответ ОК, а не версия elm адаптера), то такой адаптер нестандартные протоколы (KWP2000) не поддерживает (ЭБУ: Январь, Микас, Делфи...Авто: ВАЗы, Chery Tiggo, Nissan, Toyota JDM...)
то связь вы не установите! И дело здесь не в программе!

Самостоятельно проверить елм можно с помощью Хобдрайва:
~ в системных настройках изменить уровень системных логов с error на trace
~ в параметрах авто выбрать шаблон строки инициализации elm: VAZ Yanvar
~ подсоединиться к елм, результат ответов посмотреть в log.txt (находится в папке с программой)


День добрый. Неделю назад наткнулся на HobDrive в Play market, но возникли проблемы с подключением. Адаптер проверку на кривость прошёл. Программа при включении его сразу находит и подключается но потом ошибка соединения и по кругу.
HobDrive(1.4.0 2015/12/04) + Lenovo A3300HV (Android 4.4.2) + ELM327 BT + Chevrolet Lacetti hb 1.6 MT 2008 года.
Аватара пользователя
Новичок
 
Сообщения: 1
Зарегистрирован: 18 дек 2015, 21:47

Re: Проблемы адаптера elm327 версии 2.1

ivkorg » 12 янв 2016, 14:29

Добрый день.
Та же проблема.
С адаптером соединяется, издает звук заводящегося автомобиля, пишет, что успешно соеденился, но через секунду связь обрывается и пишет connection error threshold. Автомобиль Lanos 1,4, ЭБУ Micas 10.3+ (на самом ЭБУ название начинается с цифр 113....). Шаблон строки инициализации выбирал и Micas 10.3 E2, и Micas 10.3 E3, и даже Micas 7,6. Результат тот же
HobDrive Demo 1.4.0 + Samsung i8262 (Android 4.1.2) + Lanos 1.4 (Micas 10.3+)
Новичок
 
Сообщения: 4
Зарегистрирован: 12 янв 2016, 14:17

Re: Проблемы адаптера elm327 версии 2.1

kdika » 12 янв 2016, 14:59

Лог с уровнем trace положите.
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

ivkorg » 13 янв 2016, 13:04

Не совсем понял, что значит уровень trace.
В папке hobd нашел файл log.txt. Из него нужно вырезать какой-то определенный кусок?
HobDrive Demo 1.4.0 + Samsung i8262 (Android 4.1.2) + Lanos 1.4 (Micas 10.3+)
Новичок
 
Сообщения: 4
Зарегистрирован: 12 янв 2016, 14:17

Re: Проблемы адаптера elm327 версии 2.1

kdika » 13 янв 2016, 13:08

Нет.
Экраны/настройки/системные настройки/Отладочные логи/ Сменить с error на trace
После подключиться еще раз к авто, а после положить log.txt
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

ivkorg » 13 янв 2016, 13:45

Сделал.
Весь файл лога большой, там много строк еще с предыдущих дней, не уровня trace, поэтому вырезал кусок лога, в котором по времени появлялась та ошибка, о которой писал вчера
Вложения
1.txt
(44.62 КБ) Скачиваний: 260
HobDrive Demo 1.4.0 + Samsung i8262 (Android 4.1.2) + Lanos 1.4 (Micas 10.3+)
Новичок
 
Сообщения: 4
Зарегистрирован: 12 янв 2016, 14:17

Re: Проблемы адаптера elm327 версии 2.1

kdika » 13 янв 2016, 15:13

[TRACE] 13.01.2016 12:27:50.515[OBD2Engine] -> ATL0
[TRACE] 13.01.2016 12:27:50.516[OBD2Engine] SendCommand:ATL0
[TRACE] 13.01.2016 12:27:50.592[OBD2Engine] HandleReply: OK

[TRACE] 13.01.2016 12:27:50.593[OBD2Engine] -> EXTRAINIT
[TRACE] 13.01.2016 12:27:50.596[OBD2Engine] SendCommand:ATSP5
[TRACE] 13.01.2016 12:27:50.677[OBD2Engine] HandleReply: OK

[TRACE] 13.01.2016 12:27:50.679[OBD2Engine] -> EXTRAINIT
[TRACE] 13.01.2016 12:27:50.681[OBD2Engine] SendCommand:ATAL
[TRACE] 13.01.2016 12:27:50.758[OBD2Engine] HandleReply: ?

[TRACE] 13.01.2016 12:27:50.759[OBD2Engine] -> EXTRAINIT
[TRACE] 13.01.2016 12:27:50.760[OBD2Engine] SendCommand:ATIB10
[TRACE] 13.01.2016 12:27:50.828[OBD2Engine] HandleReply: ELM327 v2.1

[TRACE] 13.01.2016 12:27:50.829[OBD2Engine] -> EXTRAINIT
[TRACE] 13.01.2016 12:27:50.830[OBD2Engine] SendCommand:ATSH8110F1
[TRACE] 13.01.2016 12:27:50.899[OBD2Engine] HandleReply: OK

[TRACE] 13.01.2016 12:27:50.901[OBD2Engine] -> EXTRAINIT
[TRACE] 13.01.2016 12:27:50.903[OBD2Engine] SendCommand:ATST32
[TRACE] 13.01.2016 12:27:50.979[OBD2Engine] HandleReply: OK

[TRACE] 13.01.2016 12:27:50.979[OBD2Engine] -> EXTRAINIT
[TRACE] 13.01.2016 12:27:50.980[OBD2Engine] SendCommand:ATSW00
[TRACE] 13.01.2016 12:27:51.043[OBD2Engine] HandleReply: ?

[TRACE] 13.01.2016 12:27:51.044[OBD2Engine] -> EXTRAINIT
[TRACE] 13.01.2016 12:27:51.044[OBD2Engine] -> SENSOR_INIT
[TRACE] 13.01.2016 12:27:51.045[OBD2Engine] SendCommand:0100
[TRACE] 13.01.2016 12:27:51.250[OBD2Engine] HandleReply: BUS INIT: ... ERROR


которые неправильно отрабатывает елм приходят ответы знак вопроса (на ATIB10 должен быть ответ ОК, а не версия elm адаптера), то такой адаптер нестандартные протоколы (KWP2000) не поддерживает (ЭБУ: Январь, Микас, Делфи...Авто: ВАЗы, Chery Tiggo, Nissan, Toyota JDM...)
то связь вы не установите! И дело здесь не в программе!


Меняйте ваш адаптер на нормальный и только после этого сможете установить связь с вашим авто.
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

ivkorg » 23 янв 2016, 00:03

Дали мне поюзать адаптер ELM327 v1.5.
Подключилось, но периодически теряет связь.
А если что-то меняешь в настройках в параметрах автомобиля, например, метод определения расхода, то после нажатия клавиши "ОК" связь с адаптером теряется в 100% случаев. Помагает только, если выйти и снова войти в программу.
PS: может не в тему. Какой метод расчета ставить для lanos 1.4 Micas 10.3+ при работе на газу (2-е поколение)? давление во впускном коллекторе? Или встроенный датчик для Micas? И отсечка топлива для газа, наверное, не должна быть установлена?
HobDrive Demo 1.4.0 + Samsung i8262 (Android 4.1.2) + Lanos 1.4 (Micas 10.3+)
Новичок
 
Сообщения: 4
Зарегистрирован: 12 янв 2016, 14:17

Re: Проблемы адаптера elm327 версии 2.1

kdika » 24 янв 2016, 01:24

ivkorg, создайте отдельную тему по вашим вопросам и проблемам.
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

elm327 версии 2.1 Sens Микас7.6

Ivan_DN » 08 мар 2016, 22:14

Здравствуйте купил eml327 mini, поставил hobdrive demo.Ставлю готовый профиль, кроме датчика вольтажа больше ничего не видит. Подскажите в чем проблема?
Начинающий
 
Сообщения: 10
Зарегистрирован: 08 мар 2016, 21:53

Re: Проблемы адаптера elm327 версии 2.1

kdika » 09 мар 2016, 10:56

Здравствуйте, Иван.
Версия адаптера 2.1? На "кривость" проверили его? Логи где?
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

Ivan_DN » 09 мар 2016, 11:02

Версия 2,1 Вот лог http://www.fayloobmennik.net/5902542
-------------------------------------------------------------------------------------------------------------------------
elm327 версии 2.1 Sens Микас7.6
Начинающий
 
Сообщения: 10
Зарегистрирован: 08 мар 2016, 21:53

Re: Проблемы адаптера elm327 версии 2.1

kdika » 09 мар 2016, 11:11

Файл не скачал.
"На данный файл установлен пароль.
Чтобы скачать его необходимо ввести пароль:"


Версия адаптера 2.1 не будет работать с микасами, читайте тут: http://hobdrive.userecho.com/topics/222 ... lm327-v21/
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

Ivan_DN » 09 мар 2016, 11:20

Сори, забыл пароль Vfibyf
----------------------------------------------------------------------------------------------------------------------
elm327 версии 2.1 Sens Микас7.6
Начинающий
 
Сообщения: 10
Зарегистрирован: 08 мар 2016, 21:53

Re: Проблемы адаптера elm327 версии 2.1

kdika » 09 мар 2016, 11:31

Строка иниц. не правильно прописана.
Должно быть: ATSP5; ATAL; ATIB10; ATSH8110F1; ATST32; ATSW00
Или можно выбрать "шаблон строки иниц." - vaz yanvar
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

Re: Проблемы адаптера elm327 версии 2.1

Ivan_DN » 09 мар 2016, 12:01

По прежнему пишет что не видит базовых датчиков ЭБУ, вот новый лог
http://www.fayloobmennik.net/5903215


----------------------------------------------------------------------------------------------------------------------
elm327 версии 2.1 Sens Микас7.6
Начинающий
 
Сообщения: 10
Зарегистрирован: 08 мар 2016, 21:53

Re: Проблемы адаптера elm327 версии 2.1

kdika » 09 мар 2016, 12:12

Меняйте ваш елм адаптер. Он "кривой".
Из вашего лога
SendCommand:ATIB10
HandleReply: ELM327 v2.1
...
SendCommand:ATSW00
HandleReply: ?
FAQ: http://hobdrive.userecho.com/forums/4-baza-znanij/topics/
Уровень trace для лога: экраны/настройки/системные настройки/отладочные логи/trace
Просьба сделать себе подпись:
HobDrive(1.5.28_lic)+ZenFone2(5.0)+VgateICar2BT+RenaultMegane3(SID305)
Аватара пользователя
Администратор
 
Имя: Дмитрий
Сообщения: 3664
Зарегистрирован: 31 дек 2013, 14:04

След.

Кто сейчас на конференции
Сейчас этот форум просматривают: Yahoo [Bot] и гости: 3